zondag 17 oktober 2010

Pwnagetool nog niet beschikbaar, dan maar update via TinyUmbrella

De hele dag heb ik zitten wachten op het beschikbaar komen van Pwnagetool en tot op dit moment nog geen spoor van het langverwachte jailbreaktool van het DevTeam. Het wachten beu, toch maar de stoute schoenen aangetrokken en een update gedaan naar 4.1 met TinyUmbrella...

Allereerst de laatste versie gedownload en tot mijn schrik ziet de interface er heel anders uit dan ik gewend was. Na wat speurwerk blijkt TinyUmbrella 4.1.9 kleine bugfixes te bevatten, maar het belangrijkste is het herkennen van alle iDevices.

Mijn iPhone 4 wordt keurig netjes herkend en na een druk op de knop save my SHSH worden de blobs voor 4.02 en 4.1 opgeslagen. Toen de TSS server gestart en de iPhone aangesloten. iTunes wordt vanzelf afgesloten en die moet je opnieuw starten.

Uiteraard moet TU blijven lopen om de baseband van 4.01 te bewaren en na het downloaden van IPSW 4.1 klik ik een beetje met het zweet in mijn handen op de herstel knop. In het loggingvenster van TU zie ik de SHSH code voorbij schieten en de restore loopt...

Na een vijftal minuten krijg ik gelukkig een 1004 fout in iTunes...ik ben nog nooit zo blij geweest met een foutmelding na een restore. Dit betekent namelijk dat de baseband update is mislukt, Godzijdank. Na een reboot verschijnt het connect to iTunes samen met een melding in iTunes dat de sim unsupported is. Klopt, die is van Vodafone, terwijl de iPhone uit een Frans abonnement komt.

Gelukkig bevat GreenPois0n meteen hacktivation, en na het in DFU modus zetten de jailbreak laten lopen. Na een reboot en een hele zooi jailbreakcode die voorbij komt, komt de iPhone keurig geactiveerd met het slide to unlock scherm en staat het loader ikoontje voor Cydia gereed.

Cydia geïnstalleerd en toen meteen ultrasn0w laten lopen, reboot en....pfff, Vodafone nl...jailbreak en unlock gelukt. Daarna herstel naar de eerdere backup en ik ben weer up and running.

Mocht je ook niet meer willen wachten op Pwnagetool, dan is deze methode goed te doen als je een iPhone 4 hebt, want let op, bij alle oudere iPhone's wordt de baseband niet beschermd en kun je niet unlocken. Oom voor mijn iPad op 4.2 Beta 3 moet ik wachten op pwnagetool met de beloofde jailbreak voor deze firmware.

- Geschreven met BlogPress voor iPad

Geen opmerkingen:

Een reactie plaatsen