zaterdag 19 juni 2010

MacBook kreupel na vervangen harddisk

Eind vorig jaar begon de witte Macbook 13" van mijn dochter kuren te vertonen. Bij het opstarten kreeg ze regelmatig een mapje met een vraagteken er op. Dat is een melding van het systeem dat de opstartschijf niet kan worden gevonden.

Na een aantal keren herstart lukte het wel, maar het was wel duidelijk dat die standaard 80 Gb Hitachi op zijn eind was. Nu is 80Gb ook niet veel voor een laptop en besloot ik de harddisk te vervangen.

Een goedkope, maar snelle en energiezuinige, vervanger is de Western Digital Blue Scorpio SATA 250Gb. Via webwinkels te krijgen voor ca €45,-. Aldus besteld en een aantal weken geleden 'even' inbouwen dacht ik!

Nu is dat uit- en inbouwen absoluut geen kunst. De handleiding staat met foto's op www.ifixit.com. Dus de boel uitzetten, batterij eruit halen, drie schroefjes losdraaien en het witte lipje van de harde schuif wordt zichtbaar.

De harde schijf trek je er zo uit aan het lipje. De schijf wordt omgeven door een flinterdunne metalen slede die met vier schroefjes vastzit. Schroefjes los, nieuwe schijf in de slede en er weer inschuiven.

Maar toen sloeg Murphy's Law toe...Wat ik niet gezien had, was dat de schroefjes verschillend waren. Twee platte en twee dunnere. Laat ik ze er nou net verkeerd op geschroefd hebben. Bij het inschuiven voelde ik meer weerstand dan verwacht door de rubberen strips die aan de zijkanten van de HD behuizing zitten.

De rubbers werden opgerold en ik moest alles er weer uit halen. Na wat gefriemel kreeg ik de strip aan één kant er weer ingeduwd en zag ik mijn fout met de schroefjes. Na dit te hebben hersteld kreeg ik de schijf op zijn plek.

Na het opstarten met Snow Leopard op USB stick bleek dat de schijf niet herkend werd. Hmm...ik weer de oude er in, zelfde probleem. Beide schijven in een case gestopt en getest met als resultaat dat ze via USB gewoon werkten. Ik vreesde een hardware probleem met de connector. Daar kwam ik niet aan zonder de hele MacBook uit elkaar te schroeven.

Dat was een aantal weken geleden. Vandaag had ik de moed verzameld om aan dit precaire project te beginnen. De handleiding op iFixit opgehaald een aan de slag met het losdraaien van alle schroeven die ik gestructureerd had neergelegd om later ook weer alles in elkaar te kunnen zetten.

Toen ik de bovenplaat met toetsenbord er vanaf had zag ik meteen iets dat niet klopte. Direct naast de schijfconnector stak een plastic contactstripje dat was doorgesneden, precies op de plek waar de slede van de schijf zit.



Bij mijn eerdere actie waar de rubberen strip werd opgerold bleek ook het fragiele metaal van de slede iets te zijn verbogen. Dat was dus ook de weerstand die ik toen voelde...de slede had de connector van het infraroodoog en de powerled doorgesneden. Deze zit vast aan de HD connector met een minuscuul connectortje waar ze de voeding van krijgen. Kregen in mijn geval.

Nadat ik de strip had losgemaakt ging de schijf ook weer draaien. Waarschijnlijk was een kortsluiting door de afgerukte strip de oorzaak van het probleem. Na een aantal tests in open toestand heb ik alle schroeven, op één na, weer vastgeschroefd. Waar dat ene overgebleven schroefjes zat weet ik echt niet meer, maar ja.

De nieuwe harde schijf zit er in en is nu uitgerust met de laatste updates van Apple's moederschip in Cupertino. Alles functioneert weer prima, op de twee stroomloze onderdelen na; het infrarood oog en de powerled, maar dat is beter dan een helemaal onbruikbare Mac...I fixed it, nou ja, kind of...

- Geschreven met BlogPress op mijn iPad

Geen opmerkingen:

Een reactie plaatsen